由于之前Eclipse里面有一个可移植性的web工程,但是在我很久没用后,再次登录这个IDE的时候就发现了问题。 首先,我的电脑里面有两个版本的JDK,1.6和1.7。两个版本的Tomcat6和7以及两个版本的Eclipse IDE 3.5和4.0+。 当我启动开发环境后,想要向server中添加应用,发现报错: There are no resources that can be added or removed from the server. 我之前好用的应用怎么回不好使呢。于是删除server再次添加,当我添加tomcat6时,发现如下报错: Tomcat version 6.0 only supports j2ee 1.2 1.3 1.4 and java ee 5 web modules. 当我添加7时,发现如下报错: Project facet java version 1.7 is not supported 看到上面的报错,不用想了!肯定是版本的问题了! 这就奇怪了,怎么6和7都不好使了呢。上网搜索一下资料,原来工程有个文件:org.eclipse.wst.common.project.facet.core.xml

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <fixed facet="wst.jsdt.web"/>
  <fixed facet="jst.web"/>
  <fixed facet="java"/>
  <installed facet="java" version="1.7"/>
  <installed facet="jst.web" version="3.0"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
</faceted-project>
这个文件中配置了工程的编译使用的jdk,以及jst.web的版本,可以发现了,我上面配置文件中使用的1.7但是我本机的JDK是1.6. 因此把这个换成1.6测试,相应的jst.web换成2.5,就成功了。具体这个配置文件的作用,还需要研究下tomcat。查看资料也没找到这个配置文件的说明。发个博问问问吧。